Among the many improvements of .NET 2.0 is a subtle but welcome one in GridView, the replacement to the DataGrid control.
The Items have finally left the building. Any old kinda grid control should have columns and rows.
The DataGrid had Columns and Items?
What in the world is an Item? It's a row, but it's not called that -- for a very good reason I am sure.
The GridView has Columns and Rows!
Instead of ItemCreated, or ItemDataBound event handlers, there are RowCreated and RowDataBound. Instead of ItemType there is RowType.
I cannot tell you how confusing this was for developers when first working with the DataGrid. "How can I access a row?" must have been screamed at monitors from Mountain View to Mumbay.
What things are named can greatly affect how easy/hard it is use someone else's interface or maintain code. How many times have you written code for something, only to find the same functionality in an obscurely/badly named function or class?
Consistent, meaningful naming makes it much easier for someone else, or the future you (go read some code you haven't touched in a year) to get what you are trying to do.
I must confess that I have not always been the best practioner. My original programming platform was the Apple II, and variable names were limited to 8 characters (only the first three of which were meaningful -- found that out the HARD way), and I've never fully overcome the combined effects of that and my Modified Hunt & Peck Typing skills.
This is something I have worked to be better at, but this post from Ryan Olshan really made it hit home. I will paraphrase his thesis as "Variable names should be like characters in novel, they should be easily identifiable and make the reader care what happens to them".
Especially with Intellisense and the built-in refactoring tools in Visual Studio (this one especially), there is no reason to skimp on meaningful naming and it's easy to fix past mistakes.